Blogger

  • This email address is being protected from spambots. You need JavaScript enabled to view it.

    Recent items

Login

This email address is being protected from spambots. You need JavaScript enabled to view it. says: "yesterday all work fine, today nothing!".

This is a good good morning. We start our application and this morning we receive this error into the File Picker.

We are working on a custom field, so first of all we start to:

  • Debug a lot: result KO
  • clean our site collection with all customization: result KO
  • IISReset: result KO
  • Restart server: result KO

During the first step, our log says:

"Name=Request (GET:http://test.virtualsp.com:80/_layouts/AssetPortalBrowser.aspx?&AssetUrl=/...."

and

"Error while executing web part: System.NullReferenceException: Object reference not set to an instance of an object.    
 at System.Xml.Xsl.XslCompiledTransform.Load(MethodInfo executeMethod, Byte[] queryData, Type[] earlyBoundTypes)    
 at Microsoft.Xslt.STransform.GetCompiledTransform()    
 at Microsoft.SharePoint.WebPartPages.BaseXsltListWebPart.LoadXslCompiledTransform( WSSXmlUrlResolver someXmlResolver)    
 at Microsoft.SharePoint.WebPartPages.DataFormWebPart.GetXslCompiledTransform()    
 at Microsoft.SharePoint.WebPartPages.DataFormWebPart.PrepareAndPerformTransform(Boolean bDeferExecuteTransform)"

The next step was to start to ask help to Google and we found some indication regard an System Update: the KB2844286 cause this error (released on 11th July 2013). To resolve the problem, they suggest to uninstall the update: From the Control Panel and Installed Updated into the Microsoft Services. After that, if you have a virtual machine, I suggest you to restart the machine, otherwise you can restart SharePoint services and IISReset.

Published in SharePoint