Blogger

  • This email address is being protected from spambots. You need JavaScript enabled to view it.

    Recent items

Login

Thursday, 11 April 2013 21:48

SharePoint 2010 search results only for Administrator, no search results for each others

Written by
Rate this item
(0 votes)

Today, during search results test, I found a strange behaviour regards search results. If I did a query with the Administrator user, all results are displayed while when I did a search with others user, the SharePoint Search Corre WebPart returned no search results.

My instructions are supported by KB331951, which states that in order to give accounts read permissions to the tokenGroupsGlobalAndUniversal (TGGAU) attribute you need to add the account to the Windows Authorization Access (WAA) group.

Add an account to the WAA group

Here are the steps you follow to add an account to the WAA group:

  1. Log into the domain controller
  2. Click Start, point to Programs, point to Administrative Tools,
  3. Click Active Directory Users and Computers.
  4. In the Active Directory Users and Computers window, expand DomainName, and then click Users or another appropriate organization unit (OU).
  5. Double-click the SharePoint Services service account you want to modify.
  6. In the Properties dialog box, click the Member Of tab.
  7. On the Member Of tab, click Add.
  8. In the Select Groups dialog box, type Windows Authorization Access Group under Enter the object names to select, and then click OK.
  9. Restart all SharePoint services

Run a Full Crawl the SharePoint Content Source(s)

  1. Browse to Central Administration
  2. Click on Service Applications > SharePoint Search Server
  3. Run a Full Crawl on your content source(s)

Once they are done, your search results will load up just fine.

Read 5456 times Last modified on Thursday, 11 April 2013 21:58

Leave a comment

Make sure you enter all the required information, indicated by an asterisk (*). HTML code is not allowed.